CodingYourLife

CodingYourLife

 

Referenzen

 
 

Tensorflow Ubuntu Installation

Ich hatte einen ECHT SCHWEREN Start mit TensorFlow. Ich mach zwar hin und wieder was mit Linux am RaspberryPi, aber die Installation war damals nicht so einfach wie sie sein könnte. Nicht nur mir ging es so, wie dieses 1h7min lange YouTube Video zeigt https://youtu.be/zYxE3Hg275g

Ewig aufgehalten hat mich dieser Fehler:
SetupError

Und ein …“is not a supported wheel on this platform“… Fehler.
wheel

Die Lösung ist meiner Meinung nach und inzwischen (seit v0.8) einfach die Virtualenv installation durchzumachen. Für python3 bei neueren Ubuntu Versionen (weil python 3.5 vorinstalliert und 3.4 genutzt), ist ein umbenennen der Installationsdatei notwendig.

Hier ein Guide wie ihr die tensorflow-0.8.0-cp27-none-linux_x86_64.whl (Stand 04.05.2016) bzw. tensorflow-0.8.0-cp34-cp34m-linux_x86_64.whl am aktuellen Ubuntu Linux 16.04 LTS (64bit) zum Laufen bekommt. Ausgangspunkt ist eine frisch aufgesetzten VM, also sollte in der Kombination für euch funktionieren.

Dies ist nur der Guide für die CPU version (passende Grafikkarte hab ich nicht).

#maybe this isn't required anymore
sudo apt-get install python3-setuptools -y && sudo easy_install3 pip -y && sudo apt-get install python 3.5-dev -y && sudo apt-get install python3.4-dev -y
#optional but recommended: install pip, pip3, numpy
sudo apt-get install -y python-pip python3-pip && pip3 install numpy && sudo pip install --upgrade pip && sudo pip3 install --upgrade pip
#setup virtualenv for tensorflow
sudo apt-get install python-pip python-dev python-virtualenv -y
virtualenv --system-site-packages ~/tensorflow
source ~/tensorflow/bin/activate #activate virtualenv tensorflow
#install tensorflow v0.8 (old python 2.7)
pip install --upgrade https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.8.0-cp27-none-linux_x86_64.whl

Damit auch python3 verwendet werden kann, ist für neuere Ubuntu Distributionen ein workaround notwendig

#install/upgrade tensorflow v0.8 (new python 3.4) with filename workaround
wget https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.8.0-cp34-cp34m-linux_x86_64.whl
mv tensorflow-0.8.0-cp34-cp34m-linux_x86_64.whl tensorflow-0.8.0-cp35-none-linux_x86_64.whl
sudo pip3 install tensorflow-0.8.0-cp35-none-linux_x86_64.whl --upgrade

Jetzt mit sudo nano tensorflow_demo.py eine Hello World Applikation erstellen

#write a hello world tensorflow_demo.py python file like this
#!/usr/bin/python
import numpy as np
import tensorflow as tf
hello = tf.constant('Hello, TensorFlow!')
sess = tf.Session()
print(sess.run(hello))

Und ausprobieren…

source ~/tensorflow/bin/activate #activate virtualenv tensorflow
python tensorflow_demo.py #run your demo python script

Inzwischen gibt es keine Probleme mehr mit der python Version und hier auch ein Video für die GPU Version

Kommentar schreiben

Kommentar

da gibts einen fehler:

alex@as:~$ sudo easy_install3 pip -y
Searching for pip
Best match: pip 8.1.2
Processing pip-8.1.2-py3.5.egg
pip 8.1.2 is already the active version in easy-install.pth
Installing pip3.5 script to /usr/local/bin
Installing pip3 script to /usr/local/bin
Installing pip script to /usr/local/bin

Using /usr/local/lib/python3.5/dist-packages/pip-8.1.2-py3.5.egg
Processing dependencies for pip
Finished processing dependencies for pip
error: Not a URL, existing file, or requirement spec: ‚-y‘
alex@as:~$ clear

alex@as:~$ sudo easy_install3 pip -y
Searching for pip
Best match: pip 8.1.2
Processing pip-8.1.2-py3.5.egg
pip 8.1.2 is already the active version in easy-install.pth
Installing pip script to /usr/local/bin
Installing pip3 script to /usr/local/bin
Installing pip3.5 script to /usr/local/bin

Using /usr/local/lib/python3.5/dist-packages/pip-8.1.2-py3.5.egg
Processing dependencies for pip
Finished processing dependencies for pip
error: Not a URL, existing file, or requirement spec: ‚-y‘
alex@as:~$

sudo apt-get install python3.4-dev -y

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package python3.4-dev
E: Couldn’t find any package by glob ‚python3.4-dev‘
E: Couldn’t find any package by regex ‚python3.4-dev‘
alex@as:~$

Meanwhile in v0.10 you can use python 3.5. I think this is obsolete then… For me the command worked, maybe you have a different OS or something